1

I tried editing the Wiki page for , but when I click it, I am taken to the page for editing the Wiki page for . I tried the same with , but in that case, I get a error 404 page.

Could not be the problem caused by the fact the tags contain only a number, and the software is interpreting it as a tag ID? In that case, the edit link is not understood to be for , but for the tag with ID 7, which (in the database) is the ID for . I checked other edit links, and the only ones for which I have a problem are and . I will try creating and see if I have the same problem for that tag.

screenshot #1

screenshot #2

If I hover the tag itself, and I click on the edit link that appears in the drop-down menu, I am taken to https://drupal.stackexchange.com/edit-tag-wiki/425; the other edit link, which takes me to the edit page for is https://drupal.stackexchange.com/edit-tag-wiki/7. As you can see, the difference is just the number that appears as last item; this means that the code handling those URLs is not able to understand if it gets a tag name, or a tag ID. More correctly, the code that handles those URLs interprets the number passed as last component of the URL to be a tag ID, and interprets a string passed as last component of the path as tag name.

The only solution in the short term is not to use numbers as tag name.

screenshot #3

1

I just fixed this; it will be deployed shortly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .