1

what is this, I post some snippet and it tell me **body cannot contain-(after I inspect it with firebug I saw it is "_" **, what this meaning really? we can't put a snippet with "-" in question body or this is a issue in system? -

enter image description here

  • I edited the question, and I didn't get any error. May you describe exactly which part where you trying to edit, to get that error? – kiamlaluno Jul 12 '16 at 7:47
  • @kiamlaluno it was strange for me too, Also I tried to put that code here but I faced it here too.then I go to sublime and did some all replacements ( first replace all "-" to "" but error exists, then inspect the error and I findout it is "" then try to replace all "_" to "-"). really is strange – Yusef Jul 12 '16 at 8:08
  • So the problem you get is writing code containing $this->userAuth, for example. – kiamlaluno Jul 12 '16 at 8:36
  • @kiamlaluno exactly I didn't uderstand which part of my snippet cause this, the error messages was around all textarea box. maybe – Yusef Jul 12 '16 at 8:39
  • In my answer, I wrote $this->userAuth, and I didn't get any error message. I also tried with the question, but I didn't get any error message. It could be I am not editing the correct part. Let's see what a Stack Exchange developer says about this. – kiamlaluno Jul 12 '16 at 8:42
  • @kiamlaluno thank you for time and attention – Yusef Jul 12 '16 at 8:55
  • 1
    Are you using Arabic characters, by any chance? Specifically either the Arabic full stop or the Arabic tatweel? That would explain the message, as all Arabic characters are blocked on the site - because it was getting a lot of Arabic spam. – Oded Jul 13 '16 at 9:50
  • @Oded I have Persian keyboard and it is possible the reason of this error is I used "-"(this is dash in Persian keyboard) instead "-" in my question. – Yusef Jul 13 '16 at 10:34
  • 1
    OK - looks like mystery solved ;) – Oded Jul 13 '16 at 10:37

You must log in to answer this question.

Browse other questions tagged .